iXtreme LT+ Lite Touch Xbox 360 Drive Firmware Flashing
Results 1 to 3 of 3
  1. #1
    Newbie
    Join Date
    Oct 2011
    Posts
    9
    Thanks
    3
    Thanked 0 Times in 0 Posts

    First Time Flashing..Noob Question. BIOS not recognizing Phat Liteon Drive

    Background:
    I got my xbox modded by a local guy. Xbox got flagged by AP2.5 and haven't use it since then the Kinect New Dash. I learned that flashing/upgrading to LT+ 2.0 doesn't require soldering(correct me if i'm wrong) so i decided to try doing it myself this time around kaz i wanted to play Gears 3(offline of course since i'm flagged)

    Hardware/Equipment:
    Lite-On DG-16D2S(Phat)
    Windows 7 Pro x64

    I've read that the recommended way to power the Drive is to use CK3
    I also learned that It can be power by the console but it's note recommended as it'll leave traces to the xbox.
    Since i don't have a CK3 cable and my xbox is already flagged, i decided to power it via the console.

    I powered the Drive with the console, connected the drive to my PC's motherboard via a sata cable.

    But then jungleflasher doesn't recognize the liteon drive
    So i followed the instruction in the jungleflash documentation
    I did the DOSFlash thing, the DSEO thing, and the leave the drive tray half out thing then boot up thing...
    Still doesn't work.

    Later I find out that BIOS is not even recognizing the drive thru SATA.

    Is there anything i'm doing wrong in this setup?
    Is there anything i should set up in BIOS to make it recognize it?

    Thanks in advance

  2. #2
    Legend
    Join Date
    May 2011
    Location
    Holland
    Posts
    2,543
    Thanks
    34
    Thanked 359 Times in 347 Posts
    It is possible that your chipset is not compatible to flash the drive. This really happens a lot. Most users here will advice you to use/buy a via 6421 chipset card (almost always works) or a x360 usb prob wich will allow always flashing from pc or laptop.

    If your pc is up and running and you should connect your drive, power the drive and then start JF with admin rights, it should recognize the drive. if not i advise you to get your hands either on a via card or usbpro. Make sure that you refresh your com properties in JF and pick the right com port. Don't know if you already done all, but just to be sure...Good luck

  3. #3
    Xtreme Helper
    Join Date
    May 2011
    Posts
    216
    Thanks
    6
    Thanked 13 Times in 13 Posts
    I had the same problem.
    I ordered a via 6421 SATA card off ebay for 6, it worked fine

Similar Threads

  1. Flashing my BenQ drive - computer not recognizing drive.
    By Odell in forum iXtreme LT Lite Touch Download
    Replies: 11
    Last Post: 02-17-2013, 09:50 PM
  2. help regarding flashing LiteOn drive (complete noob here)
    By danveer in forum iXtreme LT+ Lite Touch Firmware Slim Support
    Replies: 1
    Last Post: 11-06-2011, 04:48 PM
  3. noob looking for help with phat liteon
    By rizkymon10 in forum Open Forum
    Replies: 4
    Last Post: 10-01-2011, 05:30 PM
  4. Quick update question for LT 1.9 to 1.91 - Liteon Phat Drive
    By fmultari in forum iXtreme LT+ Lite Touch Firmware Phat Support
    Replies: 1
    Last Post: 08-15-2011, 02:06 PM
  5. Flashing First Time (Phat) Lite-On
    By ShittyNL in forum iXtreme LT+ Lite Touch Firmware Phat Support
    Replies: 1
    Last Post: 06-25-2011, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
1e2 Forum