iXtreme LT+ Lite Touch Xbox 360 Drive Firmware Flashing
Results 1 to 7 of 7
  1. #1
    Xtreme Helper
    Join Date
    Jul 2011
    Posts
    135
    Thanks
    2
    Thanked 1 Time in 1 Post

    Does XGD3 Work On LT+2.0?

    Would a XGD3 Work On LT+2.0? Also, would the XGD3 Work On LT+2.0 if it was burnt using truncate method?

  2. #2
    Legend
    Join Date
    May 2011
    Location
    Holland
    Posts
    2,529
    Thanks
    34
    Thanked 358 Times in 346 Posts
    Lt+ 2.0 supports XGD3 backups yes.
    Only don't run those backup iso's through abgx version 1.06 otherwise you patch them for 3.0 and won't work on 2.0

    Trucate is supported with some drives but totally not recommended.

    Check c4eva speaks for drives and fw listing
    Last edited by zaxxon; 06-09-2012 at 04:42 PM.

  3. #3
    Xtreme Helper
    Join Date
    Jul 2011
    Posts
    135
    Thanks
    2
    Thanked 1 Time in 1 Post
    Quote Originally Posted by zaxxon View Post
    Lt+ 2.0 supports XGD3 backups yes.
    Only don't run those backup iso's through abgx version 1.06 otherwise you patch them for 3.0 and won't work on 2.0

    Trucate is supported with some drives but totally not recommended.

    Check c4eva speaks for drives and fw listing
    Yes but is that JUST for XGD3 or ANY backup that won't work if run through ABGX360?

  4. #4
    Legend
    Join Date
    May 2011
    Location
    Holland
    Posts
    2,529
    Thanks
    34
    Thanked 358 Times in 346 Posts
    Quote Originally Posted by dog2236 View Post
    Yes but is that JUST for XGD3 or ANY backup that won't work if run through ABGX360?
    You asked if XGD3 backups work on LT+ 2.0 and i said yes.

    You asked if truncated burns would work and i said yes some drives do support that but is not recommended at all.


    XGD2 don't need truncating, so i don't really understand your question in the second post about the abgx, explain more please.

  5. #5
    Xtreme Helper
    Join Date
    Jul 2011
    Posts
    135
    Thanks
    2
    Thanked 1 Time in 1 Post
    You said Zaxxon, "Only don't run those backup iso's through abgx version 1.06 otherwise you patch them for 3.0 and won't work on 2.0".

    So what i mean is even if i run XGD2 through ABGX, would it stop it working for LT+2.0 because it patches it for LT+3.0? Or is it only for XGD3 if you patched that wouldn't work for LT+2.0?

  6. #6
    Up and Coming Legend
    Join Date
    Dec 2011
    Posts
    808
    Thanks
    24
    Thanked 92 Times in 90 Posts
    Quote Originally Posted by dog2236 View Post
    You said Zaxxon, "Only don't run those backup iso's through abgx version 1.06 otherwise you patch them for 3.0 and won't work on 2.0".

    So what i mean is even if i run XGD2 through ABGX, would it stop it working for LT+2.0 because it patches it for LT+3.0? Or is it only for XGD3 if you patched that wouldn't work for LT+2.0?
    It goes for any AP2.5 game. Regardless of type

    Of course, games are starting to require 14719. You will need 3.0 soon. Might as well do it now

    In the case of a spelling error, I blame Tapatalk.

  7. #7
    Legend
    Join Date
    May 2011
    Location
    Holland
    Posts
    2,529
    Thanks
    34
    Thanked 358 Times in 346 Posts
    Ok, got you now.

    It's what joesinger says, all ap 2.5 games so all XGD3 games and the 6 XGD2 games that are ap 2.5. (halo reach, mw2 etc)

    All the older XGD2 games you could run them through 1.06 and it doesn't affect playing it on 2.0 or 3.0

Similar Threads

  1. Memorex and XGD3...how I got them to work.
    By JackTheRipper in forum Open Forum
    Replies: 150
    Last Post: 05-11-2013, 07:27 AM
  2. only certain xgd3 games work
    By dazuk1972 in forum Downloads and Tutorials
    Replies: 10
    Last Post: 03-09-2012, 02:18 PM
  3. XGD3 work on LT+2.0 but not on LT+3.0
    By mognjano in forum iXtreme LT Lite Touch Download
    Replies: 3
    Last Post: 02-04-2012, 05:55 AM
  4. Hitachi 59 LT2.0 XGD3 Backups Work Then Dont Work???
    By TheRegime in forum Open Forum
    Replies: 3
    Last Post: 12-27-2011, 10:30 PM
  5. XGD3 will work??
    By lordfox8 in forum iXtreme LT+ Lite Touch Firmware Phat Support
    Replies: 7
    Last Post: 10-20-2011, 04:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
1e2 Forum