Announcement

Collapse
No announcement yet.

X360 LT+ 3.0 with lastest Dashboard 2.0.17511.0 (Release : 11/17/2016)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • X360 LT+ 3.0 with lastest Dashboard 2.0.17511.0 (Release : 11/17/2016)

    Hi,

    I have a Xbox360 Lite-on DVD drive LT+3.0 and recently I took the chance to 'auto' update (not using USB) to Dashboard 2.0.17511.0.
    Guess what? All my backup discs don't work anymore.

    Ease and re-write LT+ 3.0, still doesn't work. I thought they have given up 360.

    Anyway, anyone knows what should I to do next? Thanks in advance.

    Regards,

  • #2
    You must have been on a really old dash and its changed your drive revision, read JF tutorial and then reflash your drive
    Rules To Follow

    ABGX Settings

    CG Pro Gaming Tournaments

    I will no longer help via PM's sorry

    Comment


    • #3
      Hi Slick, Thanks for the advise. I did update to one version before dash 2.0.17511.0 online. There was no problem. But I have to admit I'm using a very old 360 machine (Oops, year 2008).

      Maybe I should try to spoof the firmware one more time. Btw, I'm using JF+Dosflash. Thanks.

      Spec: Lite-On PLDS DS-16D2S 74850

      Regards,

      Comment


      • #4
        The age of your console wont make a difference, yeah try to flash your drive again using LT+3.0 02510C firmware as this is what your drive revision is now. Do you have the dvdkey already? Have you read JF tutorial?

        PS:Use JF only dosflash is ancient
        Rules To Follow

        ABGX Settings

        CG Pro Gaming Tournaments

        I will no longer help via PM's sorry

        Comment


        • #5
          Hi Slick,

          I had already re-flashed before my first posting. I flashed it backed to stock firmware (78450C) yesterday, tried a few original games, auto connect to live and again re-flashed it to LT+3.0 02510C. Unfortunately, it didn't work. Yes, I have the dvdkey. All original discs work on both stock and LT+3.0 firmware.

          I have been flashing since LT+1.1. Yes, have read the JF tutorial. Unsure now, strange . Did I missed anything?

          Regards,

          Comment


          • #6
            Very strange send me your JF log I'll check over that for you, only thing that looks wrong with your reply is stock firmware 78450 it would have been stock 02510C but of course that wouldn't effect backups, I've looked into it for you and other people have updated with no problems, I would also try running a backup through ABGX and then burn again to see if that helps
            Rules To Follow

            ABGX Settings

            CG Pro Gaming Tournaments

            I will no longer help via PM's sorry

            Comment


            • #7
              Never had I need to flash black to stock before updating new dash. Yes, I notice I should flash back to stock 02510C but strangely 78450 works (without HD). Let me try a few more times and come back to you. Thanks.

              Comment

              Working...
              X